[contributions(DRUPAL-5--4):sime] /modules/ecommerce/docs/developer/hooks ec_customer.php /modules/ecommerce/contrib/ec_commission ec_commission.module /modules/ecommerce/ec_checkout ec_checkout.module /modules/ecommerce/ec_customer ec_customer.module /modules/ecommerce/ec_receipt ec_receipt.module /modules/ecommerce/paypal paypal.module /modules/ecommerce/store store.install store.module
User: sime Branch: DRUPAL-5--4 Date: Sun, 16 Mar 2008 15:01:37 +0000 Added files: /modules/ecommerce/docs/developer/hooks ec_customer.php Modified files: /modules/ecommerce/contrib/ec_commission ec_commission.module /modules/ecommerce/ec_checkout ec_checkout.module /modules/ecommerce/ec_customer ec_customer.module /modules/ecommerce/ec_receipt ec_receipt.module /modules/ecommerce/paypal paypal.module /modules/ecommerce/store store.install store.module Log message: * Added first couple of ec_customer.php hook docs * Very minor tweak of ec_customer_get_types() * Renamed the scary 'ec_customer_get_common_interface_hook' to 'ec_customer_get_function', and modified it so that it would check for both possible implementations of a function. Really made the logic simpler, appears the static handling of include files is not needed. The calling code can be simplified to: if ($function = ec_customer_get_function($ctype, 'customer_search')) {... and thus removing a lot of redundant code (see changes to ec_customer_ec_search) * renamed ec_customer_get_id() since in every case the return is a full-blown customer object - hence changed it to ec_customer_get_customer. Note: have not changed the hook 'customer_get_id' since it is mainly returning an exid - perhaps though it should be renamed 'customer_get_exid'. * Made the code in ec_customer_get_id (now ec_customer_get_customer) much clearer, but didn't really change the logic. Links: http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/docs/dev... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/contrib/... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/ec_check... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/ec_custo... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/ec_recei... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/paypal/p... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/store/st... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/store/st...
participants (1)
-
drupal-cvs@drupal.org