[drupal-devel] [bug] $teaser misnamed in themes (theme_node)

robertDouglass drupal-devel at drupal.org
Mon Aug 1 12:57:56 UTC 2005

Issue status update for 
Post a follow up: 

 Project:      Drupal
 Version:      cvs
 Component:    theme system
 Category:     bug reports
 Priority:     normal
-Assigned to:  Anonymous
+Assigned to:  robertDouglass
 Reported by:  robertDouglass
 Updated by:   robertDouglass
-Status:       patch (code needs review)
+Status:       patch (ready to be committed)
 Attachment:   http://drupal.org/files/issues/main_teaser2.patch.txt (3.16 KB)

Updated so that it still applies.


Previous comments:

Wed, 13 Jul 2005 17:46:43 +0000 : robertDouglass

Attachment: http://drupal.org/files/issues/main_teaser.patch.txt (3.1 KB)

The documentation to theme_node clearly says the the parameter $teaser
is "Whether to display the teaser only, as on the main page." Naming
this parameter $main in the themes is confusing. Main is used elsewhere
to mean "whether to show full view or teaser view", but the meaning of
$teaser seems to be subtly different. 

An alternate to the patch I'm suggesting would be to eliminate $teaser
altogether, system-wide. The variable $main makes it clear that it is
transmitting state (whether or not on the node's main page), whereas
the variable $teaser makes on think it is transmitting the actual


Wed, 13 Jul 2005 22:41:52 +0000 : Thox

I don't follow your logic why $teaser needs to be renamed, especially if
$main is the alternative. If RSS wants to only show the teaser, does
$main=true make sense?


Thu, 14 Jul 2005 10:01:04 +0000 : Bèr Kessels

+1 from me. It removes another variable. and it increases the logic.
Instaed of using inversed logic, we now all use one single variable.


Thu, 14 Jul 2005 10:52:53 +0000 : Thox

I must have been half asleep. It does make sense, and it is logical.


More information about the drupal-devel mailing list