[drupal-devel] [bug] Category selection does not work with Movable Type blogapi

Dries drupal-devel at drupal.org
Sun Jun 19 20:25:57 UTC 2005

Issue status update for http://drupal.org/node/24030

 Project:      Drupal
 Version:      4.6.1
 Component:    blogapi.module
 Category:     bug reports
 Priority:     normal
 Assigned to:  walkah
 Reported by:  mrmachine
 Updated by:   Dries
 Status:       patch

Actually, this is an annoying property of node_save() ...  I guess you
can't use node_invoke_nodeapi($node, 'insert') or
node_invoke_nodeapi($node, 'update')?


Previous comments:

June 1, 2005 - 00:38 : mrmachine

Using a blog client (linux - either Drivel or BlogTK) and the Moveable
Type api, you can retrieve categories and select one for your post, but
once the post is submitted, it fails to allocate the category - making
the use of a blog tool pretty useless.


June 1, 2005 - 00:45 : laura s

I use ecto, set to MoveableType API,but so far I'm not able to repeat
this problem. 

Could it be the client? I was also able to set Drupal's BlogAPI to the
MetaWeblog setting and it seemed to work fine -- even with ecto set to
MoveableType API. You might be able to try that as a workaround.


June 2, 2005 - 14:04 : mrmachine

I tried ecto on my son's Windows box, and yes - it does set categories
correctly ... too bad there's no linux version 

but anyway, i tried changing Drupal's blogapi to Metaweblog, and kept
Drivel and BlogTK set to Moveable Type API. It didn't work for Drivel,
but it did for BlogTK ... thanx for the hint!


June 5, 2005 - 16:36 : fflewddur

I've been trouble-shooting this issue using w.bloggar on Windows and
Drivel on Linux.  w.bloggar is able to post using the Movable Type API,
but the category selection only works if you click "Post", not "Post and
Publish".  Drivel, by default, publishes all posts, which is why the
category never shows up when using Drivel with Drupal.  To post entries
with categories to an official Movable Type implementation, the client
must first post the entry, then call mt.setPostCategories, and then
call mt.publishPost.  The mt.publishPost call is what seems to be
confusing Drupal, as it doesn't appear to differentiate between a post
that has been published with one which has.  Movable Type does not
publicly display posts which have not been published; it considers them
as drafts which the author has not yet finished.  Thus, Movable Type
servers require the mt.publishPost call.

I have Ethereal traces of several example posts to Drupal using both
w.bloggar in "post" and "post and publish" mode, as well as Drivel.  If
you think they'd be useful in debugging, let me know and I'll forward
them on to you.



June 9, 2005 - 05:57 : mrmachine

has anyone had a chance to look at this since Todd debugged it?


June 13, 2005 - 22:56 : mrmachine

can someone have a look at this?


June 14, 2005 - 02:05 : walkah

Attachment: http://drupal.org/files/issues/blogapi-publish-post.patch (634 bytes)

having a look - it seems that mt.publishPost may well have been wiping
the term info set by setCategory.

As I only have ecto available to me currently, I can't test this
patch... but if I understand the debugging work correctly - this should
fix it. (the difference being ecto and MarsEdit - the two that I have
access to currently - don't call publishPost).

please confirm this fixes things... thanks. (I'll test more when I'm
home again at the end of the week).


June 15, 2005 - 01:06 : mrmachine

beauty! this has fixed it for me!



June 15, 2005 - 06:29 : baudolino

This is not fixed until a decision about whether to commit this patch is
made. Reverting this to patch status.

More information about the drupal-devel mailing list