[drupal-devel] [bug] Problem with recent form_item / form_select change

wiz drupal-devel at drupal.org
Sun Mar 20 20:50:25 UTC 2005

Issue status update for http://drupal.org/node/19011

 Project:      Drupal
 Version:      cvs
 Component:    taxonomy.module
 Category:     bug reports
 Priority:     normal
 Assigned to:  Anonymous
 Reported by:  wiz
 Updated by:   wiz
 Status:       patch

Hmm... I agree that it seems to work (tried it right now), but the
generated HTML is not clean:
<select name="edit[taxonomy][][]" multiple="multiple"  size="8"
id="edit-taxonomy]["><option value="1">...
Note the "edit[taxonomy][][]", which should read "edit[taxonomy][]".  I
don't clearly remember in what situation it didn't work for me, but it
happened.  The patch fixes this situation.  The id is not pretty
either, but that's another story.


Previous comments:

March 16, 2005 - 22:23 : wiz

Attachment: http://drupal.org/files/issues/taxonomy-multiple.patch (517 bytes)

_taxonomy_term_select has been changed to use form_select instead of
return form_select($title, $name .'][', $value, $options, $description,
$multiple ? 'size="'. min(12, count($options)) .'"' : 0, $multiple);
This breaks when $multiple is TRUE, as form_select will add "[]" to
$name again!


March 18, 2005 - 09:31 : Steven

Perhaps it's better and cleaner to fix this by checking the type of
vocabulary when validating the terms. In fact there is a bug there at
the moment where you could still assign multiple terms in a signle
select vocabulary by sending out customized POST data.


March 18, 2005 - 20:16 : drumm

I don't think it is actually broken. I just submitted a new node with
two terms selected from each of two vocabularies. And it worked.

More information about the drupal-devel mailing list