[development] Rename hook_menu ?
development at istyledthis.nl
Tue Dec 12 11:40:32 UTC 2006
To be honoust I prefer hook_link(), which did little of what we have
now in the drupal 2/3 era..
But still, what ever we do with hook_menu() we _are_ always
generating links, right?
Op 12-dec-2006, om 12:33 heeft Zohar Stolar het volgende geschreven:
> It's true, but hook_menu is, after all, dealing with paths and links.
> Paths and links are what allows us to navigate inside a site, and
> they are commonly combined in a menu.
> If we checked it statistically, I'm sure we would have found that
> most of the items in the menu hook are not actually visible as menu
> items, but when thinking of a menu i a larger context, we find it's
> not at all a bad name.
> A menu is a representation of a site's structure, whether it's a
> logical structure, or a more physic one. So in this way - even if
> an item is not visible, it's still part of the structure, and as a
> result - has its place in the menu.
> Karoly Negyesi wrote:
>> Today it was raised in #drupal that hook_menu has so little to do
>> with menus nowadays that
>> is likely to be a better name for the system. Thoughts are
>> welcome. MVC flames are not.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the development