[development] Rename hook_menu ?

Khalid B kb at 2bits.com
Tue Dec 12 14:07:30 UTC 2006

I agree that hook_menu() is better off renamed.

This hook is the core of Drupal, and old timers know what it is. For new
comers, it is not obvious why it is called menu.

hook_router() seems like the best choice so far, the menu items "route"
requests to different functions.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.drupal.org/pipermail/development/attachments/20061212/24152fd0/attachment.htm 

More information about the development mailing list