[development] Rename hook_menu ?
gabor at hojtsy.hu
Tue Dec 12 15:14:17 UTC 2006
On Tue, 12 Dec 2006, Morbus Iff wrote:
>> But still, what ever we do with hook_menu() we _are_ always generating
> I don't think we're generating links. I think we're generating URLs.
> I don't like hook_control. Far too generic. hook_router maybe.
I called this URL registry component in my small OO based PHP CMS
(developed a few years go) the "router". This was implemented in Class
Router. I am not sure though that the menu hook should be renamed at all.
More information about the development