[development] Rename hook_menu ?
metzlerd at evergreen.edu
Tue Dec 12 16:10:34 UTC 2006
I agree. We are basically defining the entry points and access control
to the appliction. Yes, it's more than a menu, but I don't find it to
be fully fledged "controller" either. And calling it a controller sort
of hints incorrectly at that it does more than you'd think.
In short, I don't find the use of menu innapropriate enough or feel that
the other replacement terms communicate more to a new developer. Menu is
From: development-bounces at drupal.org
[mailto:development-bounces at drupal.org] On Behalf Of Zohar Stolar
Sent: Tuesday, December 12, 2006 3:34 AM
To: development at drupal.org
Subject: Re: [development] Rename hook_menu ?
It's true, but hook_menu is, after all, dealing with paths and links.
Paths and links are what allows us to navigate inside a site, and they
are commonly combined in a menu.
If we checked it statistically, I'm sure we would have found that most
of the items in the menu hook are not actually visible as menu items,
but when thinking of a menu i a larger context, we find it's not at all
a bad name.
A menu is a representation of a site's structure, whether it's a logical
structure, or a more physic one. So in this way - even if an item is not
visible, it's still part of the structure, and as a result - has its
place in the menu.
Karoly Negyesi wrote:
Today it was raised in #drupal that hook_menu has so little to
do with menus nowadays that
is likely to be a better name for the system. Thoughts are
welcome. MVC flames are not.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the development