[development] Rename hook_menu ?
cxjohnson at gmail.com
Wed Dec 13 15:36:09 UTC 2006
I was similarly confused about hook_menu's name the first time, like
Michael. But I also agree with Gerhard (killes) that gratuitous name
changes should be avoided (although I propose to rename all plural
database table names to the singular).
Given that, I think that hook_dispatch() by far best captures what the
hook really does. It's really a jump table or dispatch table that one
ends up coding in the implementation, anyway.
I'm afraid hook_router does not sound right to me. Router has too
many other possibilities in English and in computer technology
terminology. Router is too "squishy" and vague. Dispatch nails it
right on the head. IHMO, of course.
More information about the development