[development] Rename hook_menu ?
larry at garfieldtech.com
Thu Dec 14 05:22:44 UTC 2006
On Wednesday 13 December 2006 12:24, Earl Miles wrote:
> Rob Barreca wrote:
> >> As we are going to completely overhaul the menu system in Drupal 6,
> >> this is the right time to make semantic improvements.
> > So hook_router() gets my vote as hook_dispatch() is a bit confusing to
> > me and I assume the less-technical developers feel the same about
> > dispatch (I have no idea what a dispatch table or jump table is).
> Naturally I prefer dispatch to router =)
Personally I prefer dispatch. To me "router" is a networking device. This is
a function dispatcher.
To "less technical" people, both terms are meaningless. :-) I find dispatch
to be more descriptive.
Larry Garfield AIM: LOLG42
larry at garfieldtech.com ICQ: 6817012
"If nature has made any one thing less susceptible than all others of
exclusive property, it is the action of the thinking power called an idea,
which an individual may exclusively possess as long as he keeps it to
himself; but the moment it is divulged, it forces itself into the possession
of every one, and the receiver cannot dispossess himself of it." -- Thomas
More information about the development