[development] when we run out of characters

Richard Morse remorse at partners.org
Thu May 18 19:11:50 UTC 2006

On May 17, 2006, at 7:20 PM, Jeremy Epstein wrote:

> I have another suggestion - and this time it's a serious one. How
> about changing it so that we literally put the word 'hook' into all
> hook implementations?
> So whereas now we have: function user_menu()
> Instead we would have function user_hook_menu()

I like this idea.  Extent code should be able to be fixed  
programatically (we have a finite list of hooks), and this method is  
self-documenting; it makes it clear which functions are hooks and  
which aren't.


More information about the development mailing list