[development] standard dotinfo file "package" classification
morbus at disobey.com
Sat Nov 25 16:29:01 UTC 2006
> Modules that extend a particular "parent" module, such as CCK, Views,
> Organic Groups, etc. use the "parent" module's name as the package. I
> think you'd use this when your module would basically be completely
> useless on its own without said parent module.
I think this should be the /only/ standard. If we meant "package" as
"category", then we would have named it "category". There are three
different names being bandied about here. I will define them:
* package: *closely* related modules -- probably require each other.
* distribution: a single tarball generated from the d.o release system.
* category: the general type of module or feature it provides.
In the realm of .info files, currently we only care about package and
distribution. I have /no problem what so ever/ with defining "category"
to match d.o entries. But "package" should not be used for this.
> Modules that are not useless on their own tend to be classified by
> their function, such as Voting, Development, etc. There doesn't appear
> to be any standardization here, but it probably makes sense for the
> Drupal.org category name and package name to match.
The problem with using category as a sorting function on admin/modules:
* People generally can't categorize correctly.
* "category" in an .info file is a lot slower to change than the
category list on d.o - we'll get out of date within, oh, a month.
* modules can be more than one category on d.o, and thus, so should
the .info files allow. but if we based admin/modules on category
(or even if we abused "package" in this way), then a module with
three categories would be categorized under what? the first entry
in the .info file? this would become a huuUge mess. people don't
categorize in the same way as everyone else - this is why free
tagging is so great.
I support a patch to rename "Uncategorized" to "Other".
I support any of my emails being munged into a documentation page.
> I've done a grep of contrib-head: http://drupal.pastecode.com/8783
Of this list, I'd only keep:
Bot (disclouse: this is mine)
Chat (maybe: would need to investigate more)
Voting (but ONLY if it uses/requires eaton's VotingAPI)
And taxonomy_list needs to be corrected immediately - it abuses
itself into "Core - optional", which it most certainly isn't.
Morbus Iff ( you shouldn't have come here )
Culture: http://www.disobey.com/ and http://www.gamegrene.com/
icq: 2927491 / aim: akaMorbus / yahoo: morbus_iff / jabber.org: morbus
More information about the development