[development] new CVS branch/tag conventions (was Re: tagadelic 'backport' for 4.7)
drupal at dwwright.net
Wed Oct 4 07:52:03 UTC 2006
On Oct 3, 2006, at 10:56 PM, Dries Buytaert wrote:
> On 10/3/06, Derek Wright <drupal at dwwright.net> wrote:
>> i think we're pretty much decided on that naming
>> convention (-- as the delimiter between the core API branch and the
>> contrib module's major revision number)
> I'm OK with that, if things are set in stone.
well, that's the question... at the talk i gave at drupalcon (http://
drupal.org/node/86694), everyone hated using an underscore '_' for
"DRUPAL-4-7_1" as the 1st development branch compatible with 4.7.x, and
"DRUPAL-4-7_1-0" as the 4.7.x-1.0 release tag
there were a few alternatives proposed during the discussion for a
different delimiter than '_', such as '-V-', '-R-', '-REV-', etc.
at barcamp, when i had a chance to speak to dries about it, he
suggested (and i like) just using '--'. so, here are the viable
contenders for branch and tag names:
1) "DRUPAL-4-7--1" and "DRUPAL-4-7--1-0"
2) "DRUPAL-4-7-V-1" and "DRUPAL-4-7-V-1-0"
3) "DRUPAL-4-7-R-1" and "DRUPAL-4-7-R-1-0"
4) "DRUPAL-4-7-REV-1" and "DRUPAL-4-7-REV-1-0"
5) "DRUPAL-4-7_1" and "DRUPAL-4-7_1-0" (just for comparison, this
isn't a contender)
this is your last chance to object to #1 being what we use. if
anyone strongly protests (with a better suggestion), please speak up
now or forever hold your peace. i don't want any sniveling
complaints about this in 3 weeks when it's all live and you have to
start using it, since it'll be too late to change at that point.
p.s. aside from this detail about the delimiter, for a pretty
thorough but concise summary of how the new release system will work,
you should read the 1-page handout i passed out at the druaplcon talk:
again, speak now, or love every bit of it and forever shut-up about
your complaints. ;)
p.p.s. it doesn't *really* matter, but if a module's version number
is "4.7.x-1.0", the "4.7.x" part is clearly the API-compatibility
version. the "0" is obviously the patch level. what should we call
the "1"? is that the major revision or the minor revision? in my
email quoted above, i called it "major", but does it make more sense
to refer to this as the "minor" revision, and think of the API-
compatibility stuff as the "major" revision? just curious what folks
think, if anyone else actually cares about this. ;)
More information about the development