[development] code names for core releases?

Khalid B kb at 2bits.com
Wed Sep 20 00:32:08 UTC 2006

On 9/19/06, Richard Archer <drupal.org at juggernaut.com.au> wrote:
> At 7:59 PM -0400 19/9/06, Trae McCombs wrote:
> >Richard, please just go with a +1 or -1 for the idea.
> My -1 for names has already been posted.

Fair enough.

> If we must use a name, HEAD is just fine.

Richard, can I reiterate the arguments already made against this?

Regarding HEAD/Trunk/cvs.

HEAD is transient. Today's HEAD and not tomorrow's HEAD. If an issue
or a documentation page refers to HEAD, what release exactly does this
correspond to? Look at an issue from a year or two ago that refers to
HEAD. Which release did the fix or the problem or the documented
feature is in?

Hard to say, and to find out you have to do extensive research.

It would be easier to say 5.0, since it is the next release. But that is not
known until all the desired features go in, then a decision is made on
whether this is a major or minor release.

Who knows, maybe FormAPI 7.0 and thingamajigg will make it in the
next release and it is not 5.1 anymore, rather 6.0 ...

So, from the time 5.0 is branched till we decide on what the next number
will be a code name (bikeshed, peaceNbananas, whatever) refers to
"the next release" after 5.0. Once it gets a number we can refer to either
the number or the name since they are synonymous.

Why is this concept so hard to grasp?

More information about the development mailing list