[development] Hook ordering

Karoly Negyesi karoly at negyesi.net
Fri Jan 5 15:31:53 UTC 2007

> We need more events, and with correct names for nodeapi:
> Are you seeing what we can do here? Funny, we can add a "before
> *event*" allowing us to do things before anything is done.
> What do you think?

You guys run on another track than I do.

I am wrapping my head around renaming hook_nodeapi op foo to hook_node_foo and finding a better name for hook_load (which is not a hook). Functor came to my mind.

I am vehemently against removing hook_load and friends -- it's ridiculous to remove a good, working concept just because it's confusing to some. When I explain Drupal coding I always explain that node system can be expanded in two, orthogonal directions, one being you can create your own node types and use hook_load and friends and the other direction being hook_nodeapi

More information about the development mailing list