19 Jan
2009
19 Jan
'09
2:48 a.m.
User: mgn Branch: DRUPAL-6--1 Date: Mon, 19 Jan 2009 01:48:55 +0000 Modified files: /modules/gradebook gradebook.module Log message: by MGN: rewrote hook_gradebookapi_teachers and hook_gradebookapi_students so creating a new drupal role does not automatically give it teacher and student status. Also separated out common code into a helper function _gradebook_gradebookapi_role to avoid code duplication. Links: http://cvs.drupal.org/diff.php?path=contributions/modules/gradebook/gradeboo...