User: gordon Branch: DRUPAL-6--4 Date: Sun, 05 Sep 2010 06:21:11 +0000 Modified files: /modules/ecommerce/ec_paypal ec_paypal.module /modules/ecommerce/ec_receipt ec_receipt.api.php ec_receipt.checkout.inc ec_receipt.module Log message: Add 2 new functions ec_receipt_return_page() and ec_receipt_cancel_page() to unify the code to move it to a single function. This also adds 2 hooks hook_ec_receipt_return_page_alter() and hook_ec_receipt_cancel_page_alter() to allow external modules to change this path to something that maybe more appropriate. eg. if the customer has purchased a file then send them to the file download page. Links: http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/ec_paypa... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/ec_recei... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/ec_recei... http://cvs.drupal.org/diff.php?path=contributions/modules/ecommerce/ec_recei...