User: pounard Branch: DRUPAL-7--1 Date: Sun, 16 Jan 2011 13:27:12 +0000 Added files: /modules/oox/js LICENCE.txt copy.js copy.swf jquery.copy.min.js /modules/oox/lib/Lock Database.php /modules/oox/lib NullObject.php /modules/oox/lib/NullObject Interface.php Modified files: /modules/oox/lib/Formable Interface.php /modules/oox/lib Lock.php /modules/oox/lib/Optionable Dummy.php /modules/oox/lib/Registrable Dummy.php /modules/oox oox.install oox.module Log message: Fixed autoloader behavior on other module (un)installation or (de)activation, now handle autoload namespaces cache refresh, and avoid malicious crashes. Revamped Lock API, distinguished the Oox_Lock static registray from default Oox_Lock_Database implementation. Fixed some WSOD at hook_user_*() call time. There is no API change for end users. Fixed some wrong interfaces usage since naming convention change. Added a NullObject pattern abstraction, from which I'm not quite proud of. This is only the begining, I may merge it with registry implementation. Links: http://cvs.drupal.org/diff.php?path=contributions/modules/oox/js/LICENCE.txt http://cvs.drupal.org/diff.php?path=contributions/modules/oox/js/copy.js http://cvs.drupal.org/diff.php?path=contributions/modules/oox/js/copy.swf http://cvs.drupal.org/diff.php?path=contributions/modules/oox/js/jquery.copy... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/lib/Lock/Datab... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/lib/NullObject... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/lib/NullObject... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/lib/Formable/I... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/lib/Lock.php&o... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/lib/Optionable... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/lib/Registrabl... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/oox.install&ol... http://cvs.drupal.org/diff.php?path=contributions/modules/oox/oox.module&old...