User: jonathanhunt Branch: HEAD Date: Sun, 07 Feb 2010 03:48:43 +0000 Added files: /modules/digitalnz digitalnzapi.info digitalnzapi.install digitalnzapi.module digitalnzsearch.info digitalnzsearch.install digitalnzsearch.module Removed files: /modules/digitalnz digitalnz_api.info digitalnz_api.install digitalnz_api.module digitalnz_api_admin.inc digitalnz_search.info digitalnz_search.install digitalnz_search.module digitalnz_search_admin.inc Log message: Refactor to adhere to preferred module naming conventions. Add hook_digitalnzapi_search(). Return XML from digitalnzapi_do_search() instead of SimpleXML object. Process results via digitalnzapi_results(). Cache refactored to digitalnzapi.module. Links: http://cvs.drupal.org/diff.php?path=contributions/modules/digitalnz/digitaln... http://cvs.drupal.org/diff.php?path=contributions/modules/digitalnz/digitaln... http://cvs.drupal.org/diff.php?path=contributions/modules/digitalnz/digitaln... http://cvs.drupal.org/diff.php?path=contributions/modules/digitalnz/digitaln... http://cvs.drupal.org/diff.php?path=contributions/modules/digitalnz/digitaln... http://cvs.drupal.org/diff.php?path=contributions/modules/digitalnz/digitaln...