User: jpetso Branch: HEAD Date: Mon, 23 Jun 2008 18:29:23 +0000 Modified files: /modules/filefield filefield.module Log message: * Move non-button elements to the respective container form elements. That way we can encapsulate as much as possible, and that's good for grouping the code. Consequently, widget code order is now sane at last: first comes hook_widget() which decides between upload and edit widget, then comes the upload widget, and then comes the edit widget. Finally some structure where I immediately find stuff. * Move file uploading from the value callback to the submit callback. I'm pretty convinced that we don't want to upload selected files if *any* button is pressed (not just the "Upload" button). * Rename $fieldname to $field_name, like used in core CCK code. Links: http://cvs.drupal.org/diff.php?path=contributions/modules/filefield/filefiel...