User: karens Branch: HEAD Date: Sun, 02 Sep 2007 20:18:28 +0000 Modified files: /modules/date/date date.module /modules/date date_api.module date_api_forms.inc /modules/date/date_popup date_popup.module /modules/date/includes date_php4_calc.inc /modules/date/tests date_api.test Log message: Get rid of date_part_is_valid() which got too recursive and stick with just date_is_valid(); move hook_elements() to date_forms.inc so all element code is together for clarity and easier debugging; break up processing in Date module so each process is for a single element for consistency with the way things will work in the 6.x CCK port; more cleanup of the date processing and validation; Links: http://cvs.drupal.org/diff.php?path=contributions/modules/date/date/date.mod... http://cvs.drupal.org/diff.php?path=contributions/modules/date/date_api.modu... http://cvs.drupal.org/diff.php?path=contributions/modules/date/date_api_form... http://cvs.drupal.org/diff.php?path=contributions/modules/date/date_popup/da... http://cvs.drupal.org/diff.php?path=contributions/modules/date/includes/date... http://cvs.drupal.org/diff.php?path=contributions/modules/date/tests/date_ap...