[development] optimize table in cron

vlado vlado at dikini.net
Mon Dec 5 12:08:11 UTC 2005

> A big -1 on having backup and optimisation stuff in core. A big +1 on putting 
> that in contributed maintainance or database modules.

You have a point there. 

Maybe we should consider some convention of how, if at all, to extend
apis, for example database wrappers, from contrib modules. We can see
things like that being used already, although not
very widespread.

For example a module providing db_optimise() with a default catch all
code, if possible.

db_optimise_mysql() and db_optimise_pg() in other separate modules.

There is merit in being able to use the api namespaces for such
extensions, rather putting them in their own module naming convention.

I know it is not in the SQL standards, but such a thing can be a useful


More information about the development mailing list