[development] db_rewrite_sql question
dopry at thing.net
Wed Aug 16 07:00:43 UTC 2006
I think we should strive very strongly to prevent key name conflicts.
Even if it means giving them better names... It breeds much less
confusion when you have many tables....
On Wed, 2006-08-16 at 12:04 +1000, Jeremy Epstein wrote:
> Hi Dave,
> I think that you brought the 'cid' issue to my attention before. I am
> willing to let 'cid' be changed to 'cat_id' or 'category_id', in order
> to fix this problem. As far as I'm concerned, if a particular field
> name is already 'taken' by a core module, then a contrib module (such
> as category) should respect that.
> Having said that, I believe there are examples of field name conflicts
> even within core. For example, 'fid' is used both as 'file ID' (by the
> 'files' table), and as 'field ID' (by the 'profile_fields' table).
> IMHO, the most sensible route to take is to accept that field name
> conflicts are inevitable, and to make sure that db_rewrite_sql is able
> to handle them (and to improve db_rewrite_sql if it can't handle
> On 8/16/06, Dave Cohen <drupal at dave-cohen.com> wrote:
> > Nedjo,
> > I was hoping it would not come to that. But it looks like the only solution
> > that does not require changes in other people's modules. Thanks,
> > -Dave
More information about the development