[development] Rename hook_menu ?

Arto Bendiken arto.bendiken at gmail.com
Tue Dec 12 14:25:26 UTC 2006

On 12/12/06, Karoly Negyesi <karoly at negyesi.net> wrote:
> Today it was raised in #drupal that hook_menu has so little to do with
> menus nowadays that
> hook_control
> is likely to be a better name for the system. Thoughts are welcome. MVC
> flames are not.

I've actually thought for some time that the hook should be named:


...which better represents its true purpose in life: providing the
information based on which the request is dispatched to the
appropriate callback in the module.

Arto Bendiken | arto.bendiken at gmail.com | http://bendiken.net/

More information about the development mailing list