[development] Rename hook_menu ?

Anton anton.list at gmail.com
Tue Dec 12 20:25:41 UTC 2006

On 13/12/06, Arto Bendiken <arto.bendiken at gmail.com> wrote:
> I've actually thought for some time that the hook should be named:
> hook_dispatch
> ...which better represents its true purpose in life: providing the
> information based on which the request is dispatched to the
> appropriate callback in the module.

While I'm OK with hook_menu staying in place, if it was to be renamed
hook_dispatch sounds like a good option to me.

Anton (aka styro at drupal.org)

More information about the development mailing list