[development] Rename hook_menu ?

Darrel O'Pry dopry at thing.net
Tue Dec 12 19:02:52 UTC 2006

On Tue, 2006-12-12 at 11:57 +0100, Karoly Negyesi wrote:
> Today it was raised in #drupal that hook_menu has so little to do with  
> menus nowadays that
> hook_control
> is likely to be a better name for the system. Thoughts are welcome. MVC  
> flames are not.
> Regards
> NK

I'm pretty comfortable with menu as it stands. Unless we actually
decouple it from the menu system completely, I think the name is
appropriate. The fact that out menu items are built out of our
URL<->callback registry is kind of nice. I think how some of the types
are handled is a little confusing. I don't think we should have any
locked menu items. Its convenient that we don't have to define these in
two places or merge the callback/router/whatchamacallit data into the
available menu item data.

plus we already know what drupalites call their whatchamacallit.

Anarchists for Bush 2008
Why change horsemen in the middle of an apocalypse?

More information about the development mailing list