[development] Rename hook_menu ?

Rob Barreca rob at electronicinsight.com
Tue Dec 12 20:00:11 UTC 2006

I'm fine with hook_menu(). You can still define menu items in that hook 
and any change would cause more trouble than it's worth IMO.

Rob Roy Barreca
Founder and COO
Electronic Insight Corporation
rob at electronicinsight.com

Karoly Negyesi wrote:
> Today it was raised in #drupal that hook_menu has so little to do with 
> menus nowadays that
> hook_control
> is likely to be a better name for the system. Thoughts are welcome. 
> MVC flames are not.
> Regards
> NK

More information about the development mailing list