[development] Rename hook_menu ?

Rob Barreca rob at electronicinsight.com
Wed Dec 13 18:32:12 UTC 2006

> Naturally I prefer dispatch to router =) 
Rightly so, I think Views escapes the "less-technical" category. ;-)

But seriously, even though I'm just beating a dead horse here (what else 
are mailing lists for), I really don't care which way this goes.

Rob Roy Barreca
Founder and COO
Electronic Insight Corporation
rob at electronicinsight.com

Earl Miles wrote:
> Rob Barreca wrote:
>>> As we are going to completely overhaul the menu system in Drupal 6, 
>>> this is the right time to make semantic improvements.
>> So hook_router() gets my vote as hook_dispatch() is a bit confusing 
>> to me and I assume the less-technical developers feel the same about 
>> dispatch (I have no idea what a dispatch table or jump table is).
> Naturally I prefer dispatch to router =)

More information about the development mailing list