[development] deletion API summary, question

andrew morton graveltech at gmail.com
Fri Jul 21 20:53:04 UTC 2006

On 7/21/06, Dave Cohen <drupal at dave-cohen.com> wrote:
> I suggest we use a new term (perhaps "remove", "expunge", or "trash") to
> describe this thing that could mean "move to trash" or "delete from database"
> depending on configuration.  As a module developer, I like knowing that
> hook_delete means "delete from database".  And if my module needs to perform
> some task when content is moved to trash, I'd rather have a new hook_trash
> (or somesuch) be invoked.  Likewise for hook_nodeapi: $op == 'delete' or $op
> == 'trash'.

I think that's a good point to make. Modules that maintain their own
files (in my case, the audio module) are going to need to make
accomodations for the wastebin/trash concept.


More information about the development mailing list