[development] when we run out of characters

andrew morton drewish at katherinehouse.com
Thu May 18 02:27:02 UTC 2006

On 5/17/06, Khalid B <kb at 2bits.com> wrote:
> On 5/17/06, Jeremy Epstein <jazepstein at gmail.com> wrote:
> > Instead we would have function user_hook_menu()
> That is an idea that is worth exploring. The amount of work that is
> needed is similar to the double underscore thing.
> It has an advantage where hook means hook. We often get newbie
> developers confused on what a hook is in the first place. This can
> help with the learning curve (e.g. grep/search all modules for _hook_
> to see what hooks get fired, ...etc.)

This would be my preference. It would make it more obvious that the
function implements a hook. I don't think I'm a total newb but I still
sometimes find myself confused about what function are implementing a
hook when scanning a new module.

More information about the development mailing list