[development] when we run out of characters
kb at 2bits.com
Wed May 17 23:59:56 UTC 2006
On 5/17/06, Jeremy Epstein <jazepstein at gmail.com> wrote:
> I have another suggestion - and this time it's a serious one. How
> about changing it so that we literally put the word 'hook' into all
> hook implementations?
> So whereas now we have: function user_menu()
> Instead we would have function user_hook_menu()
That is an idea that is worth exploring. The amount of work that is
needed is similar to the double underscore thing.
It has an advantage where hook means hook. We often get newbie
developers confused on what a hook is in the first place. This can
help with the learning curve (e.g. grep/search all modules for _hook_
to see what hooks get fired, ...etc.)
More information about the development