[development] when we run out of characters
jazepstein at gmail.com
Wed May 17 23:20:03 UTC 2006
I have another suggestion - and this time it's a serious one. How
about changing it so that we literally put the word 'hook' into all
So whereas now we have: function user_menu()
Instead we would have function user_hook_menu()
This format has a number of advantages, IMO, over some of the other
suggestions put forward:
- No new naming conventions that are currently non-standard in Drupal
(e.g. camelCase, double__underscores, totallyunseparatedwords).
- Makes it VERY clear what is a hook implementation, and what is just
another function in a module (e.g. many modules have a foo_form()
function, which is not an implementation of hook_form() - these would
become distinguishable from foo_hook_form() functions).
Of course, it still has the disadvantage of thousands of LOC needing
to be changed if we implement it. Which is why I think we really need
to consider whether our need is that urgent, that it warrants so much
effort being put into fixing up our function naming.
On 5/18/06, Khalid B <kb at 2bits.com> wrote:
> Here is the simplest solution that will work going forward.
> The current modules in their present incarnation have no issues,
> and the new naming scheme (allow only lower case letters and
> numbers, and disallow underscores) will prevent new ones from
> having name space clashes.
> There was one +1 on this from Gerhard.
> Any other objections?
More information about the development