[development] when we run out of characters
kb at 2bits.com
Wed May 17 23:56:23 UTC 2006
> > Any other objections?
> my only objection to modulename_hook() is that it will be ugly and
> harder to read for the humans (e.g. on the admin/modules page, in the
> code itself, etc). for example, the date field module for cck would
> become something like "fielddate".
If we have a hook_info, then we can put any module name in it, like
we do with node type modules today.
Or, when we get the metadata files for each module, we can have
a human friendly description in it.
> if there's no other alternative,
> personally, i'd prefer fieldDate. *ducks*
[Throws TV remote at dww ...]
> moduleName_hook() introduces case, but i think is fairly easy to
> read. this has the nice benefit of only effecting modules that want
> multiple words in their own name, instead of forcing all code to change.
It introduces Yet-Another-Variant-In-Code-Style in Drupal. This will be
more confusing for everyone.
> personally, moduleName_hook() (for the handful of modules that care,
> e.g og, cck, etc) isn't the end of the world, and requires much less
> work. code may be gold, but grunt-work code is lead, IMHO.
I can't say it is the end of the world, but then it would be too confusing.
Our code style discourages camel case, and now we will have yet
another exception ...
More information about the development