[development] death to "x.y.z" version is now inevitable

Derek Wright drupal at dwwright.net
Tue Nov 14 17:27:11 UTC 2006

woo hoo!  a lot of local testing and a tiny few lines diff to  
issue.inc (now applied to drupal.org), and the "x.y.z" version is  
hereby doomed to eventual extinction...

a) it's gone from the list of options when submitting a new issue

b) if you try to reply to an issue already marked as x.y.z, you  
immediately get a validation error:

"x.y.z is not a valid version, please select a different value."

and once more, "x.y.z" is gone from the list of choices.

c) you can still see issues marked as "x.y.z" in the issue queue when  
doing regular queries, so it's not invisible or impossible to find  
them[1].  they just can't stay this way. ;)

to re-iterate -- if you're dealing with an "x.y.z" issue, you should  
re-assign it to:
6.x-dev -- feature request
5.x-dev -- bug report/task for 5.x
4.7.x-dev bugs/tasks for 4.7.5 and beyond (now exists, for the  
DRUPAL-4-7 snapshot releases)
4.6.10 -- bugs only relevant in 4.6.10  (i'm assuming we don't want  
do do DRUPAL-4-6 snapshot builds)

won't fix/closed for anything else. ;)
(although, i guess it forces you to select a different version, so  
just use your best judgement about what old version that issue was  
from, doesn't really matter that much...)

is everyone happy with this?


[1] http://drupal.org/project/issues?projects=3060&versions=94702

More information about the development mailing list