[development] Is emailpage abandoned [not any more!]

Larry Garfield larry at garfieldtech.com
Fri Nov 17 07:26:56 UTC 2006

On Friday 17 November 2006 01:21, Dries Buytaert wrote:
> On 16 Nov 2006, at 23:54, Moshe Weitzman wrote:
> >> but, i do think that email_node is a better name for the module
> >> being discussed.
> >
> > except for the fact that we carefully avoid the use of the word
> > 'node' in our UI because regular admins and users care not about
> > our abstractions. given that, i think email_node is a poor name.
> > 'email post' or 'email post to a friend' sound better.
> I was about to say the exact same.  Using 'node' in your module name
> (or in user-generated output) is a sign of bad taste.  :)

I don't know that I'd say bad taste (says the maintainer of a module that 
has "node" in its name... <g>), but it is limiting.  email_node.module ceases 
to be accurate as soon as you add the ability to forward a page built with 
views or panels or taxonomy or any of the other useful non-node displays. :-)

Larry Garfield			AIM: LOLG42
larry at garfieldtech.com		ICQ: 6817012

"If nature has made any one thing less susceptible than all others of 
exclusive property, it is the action of the thinking power called an idea, 
which an individual may exclusively possess as long as he keeps it to 
himself; but the moment it is divulged, it forces itself into the possession 
of every one, and the receiver cannot dispossess himself of it."  -- Thomas 

More information about the development mailing list