[development] Drupal 5 installation language files

Konstantin Käfer kkaefer at gmail.com
Sun Nov 19 10:46:46 UTC 2006

> Ah, ok. Quoting from that page: "Zlib support in PHP is not enabled  
> by default. You will need to configure PHP --with-zlib[=DIR]". This  
> basically rules this out, since seamless zip handling is not  
> possible with out of the box PHP.

It's not enabled by default, that's true. But neither is GD or  
ImageMagick: "You will need to compile PHP with the GD library of  
image functions for this to work. [...] To enable GD-support  
configure PHP --with-gd[=DIR], where DIR is the GD base install  

We could enable downloading if zlib is there (which it is on probably  
95% of all production sites). Otherwise, the user has to do it  
manually (links are shown during installation) or download an  
uncompressed version (about 500 kB for a complete 4.7 translation). I  
think that's a fair compromise.

Konstantin Käfer – http://kkaefer.com/

More information about the development mailing list