[development] Cleaner and more consistent code.

ojacquet at jax.be ojacquet at jax.be
Thu Aug 2 10:27:29 UTC 2007

A while ago I suggested on d.o. to remove either db_fetch_row or
db_fetch_object. This would result in cleaner code, more consistent
function signatures and hooks. At my current work this is included in the
coding conventions, we only use mysql_fetch_object(). I'm posting this to
the development mailing because I am interested in what you, as developers,
think about this.

The original suggestion:

Example of an inconsistent hook:

More information about the development mailing list