[development] Cleaner and more consistent code.
david at fourkitchens.com
Thu Aug 2 14:41:51 UTC 2007
Considering that the "objects" we use aren't objects (in the sense of
having member functions) and arrays are more capable structures, I would
rather standardize on arrays.
ojacquet at jax.be wrote:
> A while ago I suggested on d.o. to remove either db_fetch_row or
> db_fetch_object. This would result in cleaner code, more consistent
> function signatures and hooks. At my current work this is included in the
> coding conventions, we only use mysql_fetch_object(). I'm posting this to
> the development mailing because I am interested in what you, as developers,
> think about this.
> The original suggestion:
> Example of an inconsistent hook:
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 186 bytes
Desc: OpenPGP digital signature
Url : http://lists.drupal.org/pipermail/development/attachments/20070802/1a1143fb/attachment.pgp
More information about the development