[development] Hook ordering
drupal at mclewin.com
Fri Jan 5 23:11:52 UTC 2007
Karoly Negyesi wrote:
> fit. As said, functor came to my mind -- functor_load. Might be a bad idea. Do not know yet. It took me five years to get a good translation in Hungarian for the word
I get what you are after and agree that differentiation between hooks
and whatever hook_load() is should be made.
I don't have a great answer on this myself. Functor strikes me as the
correct term but as an inappropriately challenging word. A functor to
me represents an object that is a calling proxy for an actual
implemented function. One can have multiple functors, but only one
implementation. 'callback' as the prefix term is also slightly off.
I'm not passing the function pointer into something to get called back on.
What about slight variations on either of these. func_load() or
'func' as the prefix implies more of a function rather than an object
representing a function. I'm tainted by a C++ background and may be in
the minority in how I read 'functor' vs. 'func'.
'callout' is fairly descriptive of what is happening. Something in core
is calling out to my function. As I've left this message sitting to
think about it more I find that this term sits best with me. Am I
allowed to +1 my own idea? :)
> If you want to further this discussion then give me reasons why your change is better than the current, nice, orthogonal system. I am not changing the system at all, just renaming stuff a little bit.
I like the current, nice, orthogonal system.
More information about the development