[development] Hook ordering
larry at garfieldtech.com
Sat Jan 6 03:28:38 UTC 2007
On Friday 05 January 2007 5:11 pm, Scott McLewin wrote:
> Karoly Negyesi wrote:
> > fit. As said, functor came to my mind -- functor_load. Might be a bad
> > idea. Do not know yet. It took me five years to get a good translation in
> > Hungarian for the word
> I get what you are after and agree that differentiation between hooks
> and whatever hook_load() is should be made.
> What about slight variations on either of these. func_load() or
> 'func' as the prefix implies more of a function rather than an object
> representing a function. I'm tainted by a C++ background and may be in
> the minority in how I read 'functor' vs. 'func'.
I'm going to be completely evil and toss out method_load(), since that suite
of whatever-they-are are effectively methods of a node object, just not using
> > If you want to further this discussion then give me reasons why your
> > change is better than the current, nice, orthogonal system. I am not
> > changing the system at all, just renaming stuff a little bit.
> I like the current, nice, orthogonal system.
Larry Garfield AIM: LOLG42
larry at garfieldtech.com ICQ: 6817012
"If nature has made any one thing less susceptible than all others of
exclusive property, it is the action of the thinking power called an idea,
which an individual may exclusively possess as long as he keeps it to
himself; but the moment it is divulged, it forces itself into the possession
of every one, and the receiver cannot dispossess himself of it." -- Thomas
More information about the development