[development] Rename *_load and friends
karoly at negyesi.net
Sat Jan 6 06:22:24 UTC 2007
We have had a discussion about this already under a different subject.
My opinion here is that hook_foo is something that gets implemented by N
modules and at call time these are called, one after the other. hook_menu
, hook_form_alter etc etc Note that 'hook' is always replaced by the
Despite hook_load is called a hook, it's a different animal: at call time,
only one implementation is called. Not to mention that since we have a
node information hook, 'hook' is not necessarily replaced by the module
Larry Garfield suggested calling these method_load, method_view and so on.
This I find a good idea and now would like to get opinions on this name.
Ps. By the way, theme hooks are also not hooks...
More information about the development