[development] Rename *_load and friends
gerhard at killesreiter.de
Sat Jan 6 14:56:09 UTC 2007
Karoly Negyesi wrote:
> We have had a discussion about this already under a different subject.
> My opinion here is that hook_foo is something that gets implemented by N
> modules and at call time these are called, one after the other.
> hook_menu , hook_form_alter etc etc Note that 'hook' is always replaced
> by the module name.
> Despite hook_load is called a hook, it's a different animal: at call
> time, only one implementation is called. Not to mention that since we
> have a node information hook, 'hook' is not necessarily replaced by the
> module name.
Note that "hook" is not something that Dries made up in his spare time:
We should look up the actual definition of "hook" and then apply that to
Drupal. No sense in defining our own names just for the fun of it.
More information about the development