[development] Rename *_load and friends

Peter Wolanin pwolanin at gmail.com
Sat Jan 6 18:25:50 UTC 2007

A patch for the HEAD developer docs is here:  http://drupal.org/node/107225

While everything is still referred to as a "hook", the name
placeholder in the last patch is altered to "method_".  I think these
*are* different from the other hooks, in that one module can implement
an unlimited number of node hooks (e.g. mymodulename.module can
implement story1_load(), page1_load(), press_release_load(), etc),
whose names may be totally unrelated to the module name, but can only
implement mymodulename_nodeapi().

if you don't like "method_" as an alternate placeholder, please post a
better patch.


More information about the development mailing list