[development] Rename *_load and friends
gerhard at killesreiter.de
Sat Jan 6 18:41:24 UTC 2007
Peter Wolanin wrote:
> A patch for the HEAD developer docs is here: http://drupal.org/node/107225
> While everything is still referred to as a "hook", the name
> placeholder in the last patch is altered to "method_". I think these
Isn't method something you use in OO programming?
> *are* different from the other hooks, in that one module can implement
> an unlimited number of node hooks (e.g. mymodulename.module can
> implement story1_load(), page1_load(), press_release_load(), etc),
> whose names may be totally unrelated to the module name, but can only
> implement mymodulename_nodeapi().
Yeah. So what?
> if you don't like "method_" as an alternate placeholder, please post a
> better patch.
I don't like it on the grounds that people coming from OO computing
might become confused.
People, stop making up your own terminology.
More information about the development