[development] Naming the CVS abstraction module
drupal-devel at webchick.net
Sat Jun 9 17:59:34 UTC 2007
On 9-Jun-07, at 1:36 PM, Doug Green wrote:
> Why is version_control preferred over versioncontrol?
For legibility. It's consistent with our variable naming convention,
and separating the individual words help non-English speakers who can
babelfish individual words to figure out what a particular thing is
> I thought we only
> used the underscores when the module was extending another module.
> And I
> thought we had problems with hook functions related to underscores,
> or is
> the problem only related to hook's with underscores?
I know of no such problems. The only thing I can think that would
cause a problem is if you named a function something like
my_module_insert and Drupal mistook it for a node insert hook when it
was just a helper function or something. But mymodule_insert would
have exactly the same problem.
> -----Original Message-----
> From: development-bounces at drupal.org [mailto:development-
> bounces at drupal.org]
> On Behalf Of Angela Byron
> Sent: Saturday, June 09, 2007 12:37 PM
> To: development at drupal.org
> Subject: Re: [development] Naming the CVS abstraction module
>> What do you think would be the best name for this module?
> Just want to chime in as the Coding Standards Queen, that a name such
> as version_control.module would be preferred over
> versioncontrol.module. :)
> Jakob, once you get the list of possible names down to 2 or 3, you
> might want to post a poll to the SoC group and cross-post here to get
> a definitive consensus. :)
More information about the development