[development] Convention for naming contrib hooks?
winborn at advomatic.com
Thu Oct 15 13:22:11 UTC 2009
Yes, that same issue w/ filefield caught me once too -- I believe it was
implemented earlier this year as an attempt to backport part of the File
API from core d7 to contrib d6.
I use hook_HOOKMODULE_HOOKNAME(), and see other modules doing that as
well, though I imagine there are some that use your suggestion as well;
your idea might be less likely to cause conflicts.
I'm aware of at least two contrib API doxygen scraping sites out there:
http://drupalcontrib.org/ and http://api.lullabot.com/ (and probably
I agree that we should come up with a standard naming convention (if
there isn't one already).
> Forgive me if this question is answered elsewhere- I've not found a
> comprehensive answer thus far.
> With contrib modules sprawling ever more, it's extremely hard to keep
> track of what modules implement what kinds of hooks. For example, I
> got caught by file_field's hook_file_delete() when I implemented
> media_mover_api_file_delete() which had nothing to do with this hook.
> While I renamed my function, it's challenging at best to know the
> terrain. Is there a central place where contrib developers can list
> their hooks, or a naming convention that is agreed to that would help
> with this (eg: hook_HOOKNAME_HOOKMODULE() or something)?
Drupal Multimedia available in September!
More information about the development