[development] Convention for naming contrib hooks?
arthur at 24b6.net
Thu Oct 15 13:09:49 UTC 2009
Forgive me if this question is answered elsewhere- I've not found a
comprehensive answer thus far.
With contrib modules sprawling ever more, it's extremely hard to keep
track of what modules implement what kinds of hooks. For example, I
got caught by file_field's hook_file_delete() when I implemented
media_mover_api_file_delete() which had nothing to do with this hook.
While I renamed my function, it's challenging at best to know the
terrain. Is there a central place where contrib developers can list
their hooks, or a naming convention that is agreed to that would help
with this (eg: hook_HOOKNAME_HOOKMODULE() or something)?
More information about the development