[drupal-devel] [bug] user uploads photo to profile -> getimagesize(): Read error! in /includes/image.inc on line 88

mariagwyn drupal-devel at drupal.org
Fri Jun 17 04:03:04 UTC 2005

Issue status update for http://drupal.org/node/24157

 Project:      Drupal
 Version:      4.6.1
 Component:    other
 Category:     bug reports
 Priority:     normal
 Assigned to:  chx
 Reported by:  lennart
 Updated by:   mariagwyn
 Status:       patch

Robin and Lennart,

I was starting to not feel like such a newbie until I read the material
on Diffs and Patches.  I am completely lost.  I don't use any sort of
command line interface (though I wouldn't mind learning how), so the
whole discussion went over my head.  I use ftp, dreamweaver, and web

Do you know of clear, steb-by-step instructions, that begin with a
blank screen and take me through the whole patching process?  Do I need
an extra piece of software?  Am I looking for some command line as a
part of my cpanel?  I tried downloadind the patch and replacing code. 
That was a disaster.

Sorry to be difficult, but I have to get the error fixed or the site
can't go live.  Any suggestions welcome.

By the way, what is 'HEAD'?

Than ks,


Previous comments:

June 2, 2005 - 13:33 : lennart

When a user tries to upload a photo to his or her profile the following
error occurs in the log

getimagesize(): Read error! in /includes/image.inc on line 88

I am using user.module and profile.module, but NOT image.module and

GD2 is working.

The problem is on a fresh 4.6.1 install without any contributed modules

I did not know exactly what component to post this under, but I think
it is important.


June 2, 2005 - 16:57 : mariagwyn

I am having the identical problem, except that I am using image.module. 
It happens anytime I click onto my images section.  I get about 8 error
messages, all the same.  It this because images are missing?  Any other



June 2, 2005 - 21:47 : rolfijn

Me to! I've installed the image-module also and get the same error. I've
allready given a 777 permision on my drupal directory, as to make sure
it's not a permissions error.

When i log into drupal and go to administration ->  settings i have the
following setting: File system path:files (which resolves to
/home/httpd/html/drupal/files, right?) and Temporary directory: tmp
(which resolves to /home/httpd/html/drupal/files/tmp, right?).

Then going to administration ->  settings -> image i see my Default
image path: images (which resolves to
/home/httpd/html/drupal/files/images, right?)

I run trustix secure linux 2.2 with the following (relevant) components

I have no idea what the problem can be. Somebody?

Thanks in advance,
Rolf Deenen


June 5, 2005 - 20:22 : Dublin Drupaller

same problem....drupal 4.6.1. import images...giving a warning:
getimagesize(): Read error!

Anyone found a solution?



June 5, 2005 - 20:51 : Dublin Drupaller

hi guys...

I downloaded the latest image.module from the cvs repository...and it


The only down side is that it is in debug mode (which means a load of
extra messages appear)...not sure how to switch that off...but, suffice
to say that it looks like the owner/maintainer/developer of the the
image_import module is on top of it.

best to wait until the module developer updates the module.



June 5, 2005 - 21:07 : celticess

I'm getting the same error but I think it only happens to the one user
using the grey box theme.  Otherwise I can't find any rhyme or reason
to it.  Everything seems to be displaying correctly.  I have the
various image modules installed though not the cvs(I am using drupal
4.6.1).  And no pictures have been uploaded to the galleries for it
even to give the error.

Also I'm getting another include error and one module specific which I
have also filed bug reports on.  The other include error though is
common.inc line 1308 and it seems no real reason for it to be pumping
out that code either.(the module error occurs only when I tell it to
show browsers in the stats filtering)  I'm not exactly a php wiz...
haven't programmed since the 80's actually so I have no idea why it's
burping out these 3 errors I'm getting.

My Drupal 4.6.1 is being run off of a debian site with php4 and mysql. 
I myself use gentoo linux(thinking about going to BSD) however my isp
TOS forbids servers or I'd run it off my own box.


June 7, 2005 - 02:43 : chueewowee

I get the same error message with drupal 4.6.0 even with all content
unpublished and all images deleted from the content. The error in all
pages even when not creating content. I sue a custom theme, but have
not altered anything relevant to images.

In fact I am having terrible problems publishing images with the
image.module and image_upload.module, in that the galleries do not show
in the create pages etc.. as a number of people have reported.


June 8, 2005 - 00:57 : occy

Yeah, I'm getting the same thing. :/  One would think with so many
people having the same issue someone would have responded with a fix. 
I guess maybe I'll try the CVS version.


June 8, 2005 - 01:31 : celticess

I put the cvs module in(I'm not running cvs drupal though just 4.6.1) in
and so far that error now seems gone.  However the other error I'm still
getting and I've got that other annoying image related problem where
you've told it to default to not promoting new uploaded images to front
page but it still does it.

Btw I wonder if the guys realize the directions for patch aren't too
clear.  I've used linux since '96 and am self taught.  Oddly enough
never had to use patch as things auto patch on gentoo.  And I've now
asked friends for plain english explaination of how to do that on my
debian host.  Why am I mentioning patch?  Because if you guys are also
having an issue with album someone has put out a patch.


June 8, 2005 - 17:05 : lennart

the problem is not specific to image.module


June 8, 2005 - 20:17 : chx

mage.inc , line 83, it's not file_exists but is_file . I suspect we'd
better change theme_image also. Someone should roll a patch. Or I'll do
when I have time :)


June 12, 2005 - 19:21 : Robin Monks

Attachment: http://drupal.org/files/issues/image.exist.patch (1.38 KB)

Here is the patch per chx's comments, I made it for him as he didn't
have time.  He can answer any questions about it.

Tested to work on HEAD.



June 14, 2005 - 03:48 : mariagwyn

I am still having the same problem.  I have tried to upload the new CVS
files for image.inc, themes.inc, and common.inc, and added the patches
listed above.  However, I get even more errors with the other CVS
files, so I reverted so I could do one thing at a time.  If I just add
the patch to image.inc and theme.inc, I simply get a blank screen.  

I am able to see my images, upload images, but if I click the /image
link (the image gallery), it gives me a blank screen with the same
error listed.

I am running 4.6.1., using a custom theme.  You may see the problem at:

I am not sure if I missed something.  Suggestions?



June 14, 2005 - 04:03 : kbahey

I faced the same issue today. 

A 4.6 install, with image.module.

At first I thought it was because of my changes to the image module,
but then the follow up email to this one popped up in my inbox with the
same exact error in the title! Spooky!


June 16, 2005 - 00:12 : kbahey

The patch fixes the problem. Had to apply the first hunk manually though
on a 4.6.1 install.


June 16, 2005 - 15:19 : mariagwyn

Can you tell me precisely how to install the patch?  I tried it once,
but it messed everything up, all sorts of bizarre errors.  As far as I
remember, I am installed 4.6.1.



June 16, 2005 - 15:49 : lennart

The patch works, but is very difficult to apply. It would be nice if it
was commited to 4.6.1 and HEAD



June 16, 2005 - 16:51 : Robin Monks

Attachment: http://drupal.org/files/issues/drupal-DRUPAL-4-6-1.image.exist.patch (1.3 KB)

The patch was designed to work on HEAD.

For those with 4.6.1, here is a backported version.

To apply either patch, refer to http://drupal.org/diffandpatch


More information about the drupal-devel mailing list