[drupal-devel] parse_rdf.inc proposal
walkah at walkah.net
Fri Sep 23 12:08:22 UTC 2005
On 23-Sep-05, at 7:14 AM, Morbus Iff wrote:
>> While updating naggregator.module, I decided to put all RDF
>> parsing stuff in one parse_rdf.inc. Naggregator needs it,
>> aggrgator.module, aggregator2.module and most probably more
>> modules could use a general rss parser.
> Don't call it parse_rdf.inc. Only two versions of RSS are actually
> RDF (RSS v0.90 and RSS 1.0) - all other versions are NOT RDF.
> parse_rss.inc is a far stronger name, but honestly, I'd name it
> something like syndication.inc or something (so as to include Atom
Agreed - this should be general parse_feed.inc (or somesuch) ... and
I would absolutely be +1 for that...
In fact, I would like to see a general xml.inc for generalized XML
parsing / generation - which then parse_feed could use to handle
specifics of feed types. PEAR currently has a package in the proposal
stage that does just this:
Might serve as some inspiration...
James Walker :: http://walkah.net/
More information about the drupal-devel