[development] FAPI's future

Angela Byron drupal-devel at webchick.net
Fri Aug 10 02:20:09 UTC 2007

On 9-Aug-07, at 6:49 PM, Jeff Eaton wrote:

> On Aug 9, 2007, at 5:30 PM, Neil Drumm wrote:
>> Another possibility is using consistent function names for forms.  
>> This
>> is how I removed the index of update functions that used to exist in
>> update.php, I required the update function names to follow a pattern
>> and finding all of them was done easily.
> This is probably a tricky one; I tend towards the expressiveness of  
> lookup tables and arbitrary function names rather than strict  
> naming conventions, but I realize that I might be in the  
> minority. ;) I wanted to use <form_id>_builder() or <form_id>_form 
> () as our standard 'constructor' function names, but the use of  
> <form_id>() ultimately won out a while back.

<form_id>_form() would be more consistent with <form_id>_validate()  
and <form_id>_submit(). A workshop student brought up this point of  
confusion in Chicago.

Too late to change it for D6 though, I guess.


More information about the development mailing list